Vacuum leak found in ‘96 EB 5.0 Bronco

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

goffprof

New member
Joined
May 24, 2008
Messages
21
Reaction score
11
Location
CT
My ‘96 EB Bronco recently began having problems with hard start, rough idle, and stalling only on startup. It triggered the Check Engine light and codes P0171 and P0174. I read several BroncoZone tech posts that helped me track down the cause to a vacuum leak in a white (plastic?) vacuum line to the “blend door actuator”. A section of the white vacuum line outside the plastic loom in the engine compartment had deteriorated and had a hole in it.

I cut the factory black tape off the plastic loom, cut out about a foot of the bad vacuum line section and rerouted the remainder back to the door actuator. That immediately fixed the hard start, rough idle problem. I’ll replace the complete vacuum line soon. I still have to clear the 2 codes with my Maxiscan MS310 OBDII scanner as there may be another issue. I’d appreciate any advice on possible other causes for having both the P0171 and P0174 (lean - Bank 1&2) codes.

Here are before and after photos of the white vacuum line leak problem and the temporary fix.

1720397698015.jpeg


1720397639999.jpeg
 
OP
OP
G

goffprof

New member
Joined
May 24, 2008
Messages
21
Reaction score
11
Location
CT
Glad you found it. I found 2 on mine this morning.
Where was the other leak in your Bronco? I’m also looking for 2 rubber 90-degree elbows for my replacement charcoal canister.

1720464606116.jpeg
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
22,557
Messages
136,260
Members
25,163
Latest member
cporan
Top