need help . 88 Bronco 2 has no power no nothing

sublime88

New member
Joined
Apr 11, 2015
Messages
3
I have an 88 Bronco 2 I got it a couple weeks ago I change the starter water pump and thermostat and starter solenoid ran fine. a couple days ago I went to the gas station ran fine got out to pay for the gas came back out no lights no power no nothing would not start.so I towed it to my house and I change the ground cable. I'm getting power to the solenoid but still no lights and won't start

 

sublime88

New member
Joined
Apr 11, 2015
Messages
3
Nope it won't. It sparks when I cross them but that's all that happens . its the weirdest thing its like I don't have a battery no lights turn on or anything. Thanks for replying

 

Seabronc

New member
Joined
May 22, 2004
Messages
7,315
Location
North of NYC
Check he condition of your battery (-) cable.  Remove all connections, clean them (including the positive connections to the battery).  That includes the (-) connections to the engine block and frame.  Check the area where the lugs attach to the cables, if there is any corrosion, replace the cable.

Good luck,

:)>-

 
Last edited by a moderator:

sublime88

New member
Joined
Apr 11, 2015
Messages
3
thanks for the information and the replies I fixed the problem there was a wire with a wire nut on it with some of the wire exposed and it shorted out and melted the wire right behind the windshield wiper fluid box but now when I turn the air conditioner on the amp gauge goes crazy

 

Members online

No members online now.

Latest posts

Forum statistics

Threads
21,503
Messages
125,394
Members
23,331
Latest member
Ole
Top