KOEO Nothing on Code Reader & Security Module

RR-Texas

Member
Joined
Oct 6, 2012
Messages
175
Location
Houston, Texas
So I still have no fuel pump and I don’t have any testing or anything through the reader and I don’t see the security module mentioned I tried searching for it. The truck actually started for a brief couple of seconds and died again, before I dropped the tank.

Think I’m too old to go back to a vehicle I have to work on regularly as my daily

Richard
 

Tiha

Member
Joined
Jul 22, 2020
Messages
59
Location
Midwest
think you have a known good pump for now. Have you ever taken a test light and verified power to it?

I believe the ecm runs a relay, power goes from the relay through the fuel shut off, safety, inertia switch, then to pump.

The inertia switch is behind the passenger side kick panel. Has a little red button on top. They do go bad. With a test light you should see power there on both sides as soon as you turn the key on. But you gotta be fast because the ecm only runs the pump for a few seconds.
 

RR-Texas

Member
Joined
Oct 6, 2012
Messages
175
Location
Houston, Texas
Hoping to go down that path today, it has power or it does intermittently. I’m starting at the beginning, but I am going to try and jump the pump relay. But my code reader is getting no information from the truck. So does the security module have any part in any of these systems? I know it won’t start without it.

While the fuel pump plug has been changed to the round connector, there is sketchy wiring throughout the vehicle. But she was great for years as a daily
 

Tiha

Member
Joined
Jul 22, 2020
Messages
59
Location
Midwest
Answered your other thread. that module does not belong there.

I would yank it. Pull the column apart and see if there are any factory wires cut and put them back together.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
21,304
Messages
123,990
Members
22,988
Latest member
tdmwi
Top