Idling issues and Passing gear

Jay1410

New member
Joined
May 3, 2020
Messages
5
Location
Fort Worth, Texas
Just bought a 1993 Bronco with the 302, 162,xxx miles and auto trans more than likely E4OD. I knew it had these issues when I bought it.

#1)The idle is ok but almost stalls or does stall at idle when the a/c is on or when turning the steering wheel at idle and in drive.
#2) It also surges/pulses (unknown if explaining it right) when accelerating at any speed. Some days are better than others.
#3) Passing gear doesn't seem to engage. When I "romp" on it to pass someone it acts like it goes to a lower gear but loses speed. I let off after that.

I have not pulled codes since I'm putting it in the shop but I just needed some ideas.

Things I know that have been replaced

1) IAC
2) ECM (cheapo $50)
3) vacuum lines to MAP but MAP not replaced
4) Neutral safety Switch ??? Looks new but unknown if replaced
5) Kick down cable not new but attached
6) Timing chain
7) Some other vacuum lines

My ideas are:
1) Clean throttle body
2) TPS
3) PCV
4) EGR
5) Make sure kick down cable works
6) Check all vacuum lines
7) Fuel Pump
8) MAP
9) Check all vacuum lines
10) Trans fluid and filter

I thought maybe the PSPS but with the a/c making it stall as well it has to be something else.

Any other ideas would be appreciated! Obviously some of these things I can replace on my own but I'd rather get it diagnosed and fixed now! I have a boat that needs to be in the water!! Other than what I listed its a blast to drive!!
 

Skitter302

Member
Staff member
Moderator
Joined
Nov 25, 2012
Messages
619
Location
WA
KOEO and KOER codes would be good to check, and report back with what you find.

Check fuel pressure also.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
21,265
Messages
123,774
Members
22,913
Latest member
Bob123
Top