84 Ford Bronco II- Turn signals not working!

ur1rose

New member
Joined
Aug 27, 2011
Messages
5
Hello,

Our 84 Ford Bronco turn signals have stopped working. A day or two before that we had just replaced our spark plugs and wires. Also, we did accidentally replace it without disconnecting the negative on the battery. bad mistake? So far, we tried replacing the fuses even though they were fine, the flasher, and even the turn signal switch. None of it did anything. We got a wiring diagram off one poster but can't really read it. I will attach it to the post. Could be a loose or disconnected wire? Please help! Thank you!

bronco wiring diagram.jpg

 

Rons beast

Active member
Staff member
Moderator
Joined
Dec 13, 2007
Messages
1,536
Age
64
Location
Florida..in my mind , sitting on the beach
First changing plugs and wires without removing the ground is no problem.

Sometimes something that has you pulling your hair out is based on something simple. If the hazard switch is ON no turn signals will work.

If that is not the case, first check that the fuses have power on BOTH sides, with the key in the run position.

If that is ok, check that there is power comming in to the turn signal flasher. (with the flasher out check for power from one of the slots)

If there is no power, you need to trace down the source,probably a purple and orange wire from the Dir/b/u fuse.

If you have power at a flasher port, jump the 2 ports and check the turn signals, (they will light but not flash)

If that works the problem is the flasher.

If not, the problem will have to be traced wire by wire to/and through the switch.

Good luck and let us know what you find.

 

Members online

No members online now.

Latest posts

Forum statistics

Threads
21,338
Messages
124,193
Members
23,060
Latest member
Grill Doc
Top