79 bronco rear window problems

Doster

New member
Joined
Jun 4, 2008
Messages
29
I have a 79 Bronco 4 speed with a 351m. I first purchased it in Highschool, and have drove it every once and a while just to keep it runing. It has been sitting for a while since last messed with but will still run if pull started. The battery is good and all lights work fine except the rear window. The rear window used to work by useing the manual Key swithch on the tailgate, but was very slow and you had to help it get started up and down. The switch in the dash has never worked, but I am wanting to fix it all and make both switches work as they are supposed to. Does anyone have any suggestions on where to start?

 
Last edited by a moderator:

bob75cj

New member
Joined
Mar 30, 2008
Messages
7
Check the wires to the gate from the body. Where the gate is hinged. Usually where the problem is. Wires break from opening and closing gate.

 

Doster

New member
Joined
Jun 4, 2008
Messages
29
I have a 79 Bronco 4 speed with a 351m. I first purchased it in Highschool, and have drove it every once and a while just to keep it runing. It has been sitting for a while since last messed with but will still run if pull started. The battery is good and all lights work fine except the rear window. The rear window used to work by useing the manual Key swithch on the tailgate, but was very slow and you had to help it get started up and down. The switch in the dash has never worked, but I am wanting to fix it all and make both switches work as they are supposed to. Does anyone have any suggestions on where to start?
Proble is fixed... Ended up cleaning some connections in the rear and degreasing the gears in the window. As for the front window switch, I had to wire a lead from the positive post on the switch to the acc fuse block and now both switches work fine to rais and lower the window perfectly.

 

Members online

No members online now.

Forum statistics

Threads
21,420
Messages
124,645
Members
23,198
Latest member
Mm66gt
Top